box-sousmenu-top
box-sousmenu-bottom
Quick troubleshooting

Security

What is the minimum configuration required to subscribe to Videotron's Security Services?

 

  • Windows 7, Windows Vista (32 bits) or Windows XP (32 bits)
  • Internet Explorer 6.0, 7.0 or 8.0
  • Please note that Windows 98SE, Windows Millennium and Windows 2000 are no longer supported.
  • We regret that Videotron’s Security Services are currently not available for the Mac platform.
  • The latest version of our Security Services is compatible with Windows 10.

 

You are already a subscriber and need to download Videotron Security Services again?

Download Videotron Security Services again

 

 

 

Has this article answered your questions?
YES
No
 
 

 

box-bg-top-247
box-bg-bottom-247
box-bg-top-247
box-bg-bottom-247